Results 1 to 2 of 2

Thread: 2006 g6 ecm question

  1. #1
    suckit
    G6 Newbie

    Join Date
    Dec 2018
    Posts
    2
    Year
    2006
    Make
    Pontiac
    Model
    G6
    Trim
    Base
    Engine
    3.5L V6 LX9
    Transmission
    4 Speed Auto
    Style
    Sedan
    Color
    Liquid Silver Metallic

    2006 g6 ecm question

    Ok Iíve done a little search. Unfortunately Iíve only got the phone to search with. Hereís what I got. I have po443 code. I have found that Iím not getting the ground from the ecm to the evap in the back by the tank. I have power but no ground. I have found the wire out of ecm and donít have ground out of it. So whatís my next step to try and solve my problem. Thanks

  2. #2
    suckit
    G6 Newbie

    Join Date
    Dec 2018
    Posts
    2
    Year
    2006
    Make
    Pontiac
    Model
    G6
    Trim
    Base
    Engine
    3.5L V6 LX9
    Transmission
    4 Speed Auto
    Style
    Sedan
    Color
    Liquid Silver Metallic

    Re: 2006 g6 ecm question

    I guess I’m wondering if there is something else I can test. what are your thoughts on if the ecm is faulty or is there something else causing single lost to the evap solenoid by the tank. Like I mentioned above, I have positive volts to the plug but not a ground which the way I understand the ecm sends a ground to the solenoid which opens the vent. Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •